Dostępne wersje PHP

Na wszystkich naszych serwerach masz dostęp do aktualnych wersji PHP 7.2, 7.3 oraz 7.4. wyższe wersje PHP zapewniają lepszą wydajność i wyższe bezpieczeństwo. Dlatego zachęcamy zawsze do migracji do nowszej wersji PHP. Możesz zmienić wersję PHP na swoim koncie w bardzo prosty sposób.

Na naszych kontach hostingowych z linii Biznes zapewniamy dostęp również do starszych wersji PHP - 5.2, 5.3, 5.4, 5.5, 5.6, 7.0 oraz 7.1. Są to wersje oficjalnie już nierozwijane. Zapewniamy jednak ich obsługę w wersji Hardened PHP, rozwiązanie dostarczane przez CloudLinux. Co to oznacza? Nawet dla PHP 5.2, którego ostatnia oficjalna wersja została wydana w 2011 roku są nadal wypuszczane poprawki bezpieczeństwa, takie jak dla wyższych wersji. Jeżeli więc posiadasz starsze oprogramowanie, którego nie możesz dostosować do wyższych wersji PHP, możesz spokojnie go używać na serwerach Biznes.

Jak samodzielnie zmienić wersję PHP na serwerze?

Oferowany mechanizm pozwala on na ustawienie wersji PHP indywidualnie dla każdej podpiętej domeny. Jeśli posiadasz starszą Joomlę, która wymaga PHP 5.6, nic nie stoi na przeszkodzie, aby Wordpress uruchomiony na tym samym koncie w innej domenie korzystał z najnowszego PHP 7.4.

Menedżer wersji PHP

Opcja ta nazywa się "Menedżer wielu wersji języka PHP" i pozwala na ustawienie różnych wersji PHP dla podpiętych pod konto hostingowe domen.

Wybór wersji PHP

Zmiana wersji PHP dla poszczególnych domen możliwa jest po zaznaczeniu nazwy domenowej, następnie "Wersja programu PHP" i klikamy "Zastosuj".

Dostępne jest również ustawienie "Edytor MultiPHP INI", które pozwala na dostosowanie parametrów PHP do własnych potrzeb. Również tutaj można ustawić parametry indywidualnie dla każdej domeny.

Parametry PHP - edytor pliku php.ini